Degraded NetID performance

Incident Report for Catholic Schools NSW

Resolved

Normal NETiD performance has been restored. We will continue to monitor it over the next few days.
We appreciate your patience during this time.
Posted Aug 29, 2025 - 14:10 AEST

Identified

We have identified a degradation in NetID performance, and our technical team is currently investigating the issue. We will provide an update shortly.
Posted Aug 29, 2025 - 12:53 AEST
This incident affected: NETiD (Web Application, API).