Some technical issues currently impacting NetID and associated applications

Incident Report for Catholic Schools NSW

Resolved

This incident has been resolved, and all systems are operational again.
Posted Aug 25, 2025 - 18:17 AEST

Identified

We have identified a technical issue currently impacting NetID and associated applications. As a result, users may be unable to log in. The cause of the issue has been identified, and our upstream provider is working to restore services. We are monitoring the situation closely and further updates will be provided as events warrant.
Posted Aug 25, 2025 - 17:06 AEST

Investigating

We have identified a technical issue currently impacting NetID and associated applications. Users may experience difficulty accessing these services. We will provide an update shortly.
Posted Aug 25, 2025 - 15:43 AEST
This incident affected: NETiD (Web Application, API), Education Facilities (Web Application, API), Learning Support (Student Management, Personalised Planning for Students with Disabilities, NCCD), and Program Grants Management, Professional Learning.